summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-03-25 15:06:39 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-03-25 15:06:39 +0200
commit44742f8aadb7a8a969f11d9b1d50c8be2573a576 (patch)
tree90c1b692df9a41627ac8413c68a569b29ae9008b /CMakeLists.txt
parent59a5b833216b62f28c816df7c9129bf0954993e0 (diff)
downloadfastd-44742f8aadb7a8a969f11d9b1d50c8be2573a576.tar
fastd-44742f8aadb7a8a969f11d9b1d50c8be2573a576.zip
Add include command
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40bdb3c..9625deb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,11 @@ endif(UECC_FOUND AND NACL_FOUND)
set(WITH_PROTOCOL_ECFXP ${CRYPTO_FOUND} CACHE BOOL "Include ec25519-fhmqvc-xsalsa20-poly1305 protocol")
+set(MAX_CONFIG_DEPTH 10 CACHE STRING "Maximum config include depth")
+
+# Ensure the value is numeric
+math(EXPR MAX_CONFIG_DEPTH_NUM ${MAX_CONFIG_DEPTH})
+
if(WITH_PROTOCOL_ECFXP AND NOT CRYPTO_FOUND)
MESSAGE(FATAL_ERROR "libuecc and NaCl are required for the ec25519-fhmqvc-xsalsa20-poly1305 protocol")
endif(WITH_PROTOCOL_ECFXP AND NOT CRYPTO_FOUND)