summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-12-24 17:14:40 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-12-24 17:14:40 +0100
commiteaac49427339a365aac2d3505f567572cfbdbb96 (patch)
treeb7a8d43aa24396d513747a9eb45d9e0fd29ce232 /CMakeLists.txt
parentcd8ab035e605c5d8f8105861b2818a54a21eb311 (diff)
downloadfastd-eaac49427339a365aac2d3505f567572cfbdbb96.tar
fastd-eaac49427339a365aac2d3505f567572cfbdbb96.zip
Add WITH_CAPABILITIES CMake flag and check for libcap
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13c0079..e2d5332 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,14 @@ pkg_check_modules(UECC REQUIRED libuecc>=2)
find_package(NaCl REQUIRED)
+set(WITH_CAPABILITIES TRUE CACHE BOOL "Include support for POSIX capabilities")
+
+if(WITH_CAPABILITIES)
+ find_package(CAP REQUIRED)
+else(WITH_CAPABILITIES)
+ set(CAP_INCLUDE_DIR "")
+ set(CAP_LIBRARY "")
+endif(WITH_CAPABILITIES)
set(WITH_CRYPTO_AES128CTR_NACL TRUE CACHE BOOL "Include the AES128-CTR implementation from the NaCl library")
set(WITH_CRYPTO_AES128CTR_LINUX TRUE CACHE BOOL "Support using the AES128-CTR implementation in the Linux kernel")