summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-15 21:52:45 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-15 21:52:45 +0100
commit3d00ddf2968711d071b537b27c3ec208b584cbdc (patch)
tree4f62485d3d51764694b802864e695434b73c62c2 /src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
parentefdd366144118b5f1a7bcef983a1888975aeefa0 (diff)
downloadfastd-3d00ddf2968711d071b537b27c3ec208b584cbdc.tar
fastd-3d00ddf2968711d071b537b27c3ec208b584cbdc.zip
Allow using blowfish from OpenSSL on systems where it's available anyways
Diffstat (limited to 'src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt b/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
new file mode 100644
index 0000000..76bce41
--- /dev/null
+++ b/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
@@ -0,0 +1,7 @@
+if(USE_OPENSSL)
+ fastd_cipher_impl(blowfish-ctr openssl
+ blowfish_ctr.c
+ )
+ fastd_cipher_impl_include_directories(blowfish-ctr openssl ${OPENSSL_INCLUDE_DIRS})
+ fastd_cipher_impl_link_libraries(blowfish-ctr openssl ${OPENSSL_CRYPTO_LIBRARIES})
+endif(USE_OPENSSL)