summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/salsa2012/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-12-01 07:40:27 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-12-01 07:40:27 +0100
commit35748654f39a99c226cd14f3b92822eb64bd7037 (patch)
tree5f9ec74d842b2c3d198dfb6e4e5d6fd5b7f9481d /src/crypto/cipher/salsa2012/CMakeLists.txt
parent8e6154d53b3904f3fe35d2b958972f7826167d46 (diff)
downloadfastd-35748654f39a99c226cd14f3b92822eb64bd7037.tar
fastd-35748654f39a99c226cd14f3b92822eb64bd7037.zip
Add fast SSE2 implementations "xmm" for Salsa20 and Salsa20/12
Public Domain implementations by D. J. Bernstein, see http://cr.yp.to/snuffle.html
Diffstat (limited to 'src/crypto/cipher/salsa2012/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/salsa2012/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/crypto/cipher/salsa2012/CMakeLists.txt b/src/crypto/cipher/salsa2012/CMakeLists.txt
index eb853e0..4821f41 100644
--- a/src/crypto/cipher/salsa2012/CMakeLists.txt
+++ b/src/crypto/cipher/salsa2012/CMakeLists.txt
@@ -1,2 +1,3 @@
fastd_cipher(salsa2012 salsa2012.c)
+add_subdirectory(xmm)
add_subdirectory(nacl)