summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-28 04:31:25 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-28 04:31:25 +0100
commitac55a91fe94b78bde373169264e6b7a180c39f04 (patch)
tree33f9a38de1e7056d02ca61c82a41e604dabdf232 /src/crypto/mac/CMakeLists.txt
parentca49096f5d02e351b928b2fd584bd7ca0d5fcf1f (diff)
downloadfastd-ac55a91fe94b78bde373169264e6b7a180c39f04.tar
fastd-ac55a91fe94b78bde373169264e6b7a180c39f04.zip
Add a pclmulqdq ghash implementation
Diffstat (limited to 'src/crypto/mac/CMakeLists.txt')
-rw-r--r--src/crypto/mac/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/crypto/mac/CMakeLists.txt b/src/crypto/mac/CMakeLists.txt
index 22bc95e..355416f 100644
--- a/src/crypto/mac/CMakeLists.txt
+++ b/src/crypto/mac/CMakeLists.txt
@@ -34,6 +34,10 @@ macro(fastd_mac_impl_require mac name)
fastd_module_require(mac "${mac} ${name}" ${ARGN})
endmacro(fastd_mac_impl_require)
+macro(fastd_mac_impl_compile_flags mac name source)
+ fastd_module_compile_flags(mac "${mac} ${name}" ${source} ${ARGN})
+endmacro(fastd_mac_impl_compile_flags)
+
add_subdirectory(ghash)