summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 16:01:16 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 16:01:16 +0100
commit4496be6e29732189769b78f63e491dacb23c961b (patch)
tree5882550f4cf9b516fdd613bbaf4535a7f59d981a /src/crypto/mac/ghash/CMakeLists.txt
parent20a95ef2731ce21acfe5c1ba97b40001217b0216 (diff)
downloadfastd-4496be6e29732189769b78f63e491dacb23c961b.tar
fastd-4496be6e29732189769b78f63e491dacb23c961b.zip
Convert ghash to the new crypto algorithm scheme
Diffstat (limited to 'src/crypto/mac/ghash/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crypto/mac/ghash/CMakeLists.txt b/src/crypto/mac/ghash/CMakeLists.txt
new file mode 100644
index 0000000..7d697e8
--- /dev/null
+++ b/src/crypto/mac/ghash/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(IMPLS "")
+
+if(WITH_MAC_GHASH_BUILTIN)
+ list(APPEND IMPLS builtin)
+endif(WITH_MAC_GHASH_BUILTIN)
+
+set(IMPL_SOURCES "")
+
+foreach(impl ${IMPLS})
+ add_subdirectory(${impl})
+
+ list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:mac_ghash_${impl}>)
+endforeach(impl)
+
+
+set(MAC_NAME "ghash" PARENT_SCOPE)
+set(IMPLS "${IMPLS}" PARENT_SCOPE)
+set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)