summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-17 11:43:06 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-17 11:43:06 +0100
commitb4c9ab9a814edfb0d735a8c2e1f0c173847c0810 (patch)
treec4a715a5e9bcbb357f00013c2ff42157899471b1 /src/crypto/mac/ghash/CMakeLists.txt
parent1b06460aa967e3afcfa6fc8d664874134ab6c739 (diff)
downloadfastd-b4c9ab9a814edfb0d735a8c2e1f0c173847c0810.tar
fastd-b4c9ab9a814edfb0d735a8c2e1f0c173847c0810.zip
Revert bytewise ghash implementation
The performance gain is negligible, and OpenSSL avoids a bytewise implementation to mitigate timing attacks. This reverts commits d4916544299c28c4fb16da6d3306eea0a6d5d79f and 1b06460aa967e3afcfa6fc8d664874134ab6c739.
Diffstat (limited to 'src/crypto/mac/ghash/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/crypto/mac/ghash/CMakeLists.txt b/src/crypto/mac/ghash/CMakeLists.txt
index 481e77f..7d44b8a 100644
--- a/src/crypto/mac/ghash/CMakeLists.txt
+++ b/src/crypto/mac/ghash/CMakeLists.txt
@@ -1,3 +1,2 @@
fastd_mac(ghash)
add_subdirectory(builtin)
-add_subdirectory(tiny)