summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 03:34:00 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 03:34:00 +0100
commiteabbb5eb368df3ff606a472bd96a4a4077a214d8 (patch)
tree211ad12c827a823949b1c5c3cc9dc4343e85ca01 /src/crypto/mac/ghash/CMakeLists.txt
parente7893cc54fb0eaba0cfe88ff44cf52a3f7ff2200 (diff)
downloadfastd-eabbb5eb368df3ff606a472bd96a4a4077a214d8.tar
fastd-eabbb5eb368df3ff606a472bd96a4a4077a214d8.zip
Improve build system for ciphers and MACs as well
Diffstat (limited to 'src/crypto/mac/ghash/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/crypto/mac/ghash/CMakeLists.txt b/src/crypto/mac/ghash/CMakeLists.txt
index 7d697e8..7d44b8a 100644
--- a/src/crypto/mac/ghash/CMakeLists.txt
+++ b/src/crypto/mac/ghash/CMakeLists.txt
@@ -1,18 +1,2 @@
-set(IMPLS "")
-
-if(WITH_MAC_GHASH_BUILTIN)
- list(APPEND IMPLS builtin)
-endif(WITH_MAC_GHASH_BUILTIN)
-
-set(IMPL_SOURCES "")
-
-foreach(impl ${IMPLS})
- add_subdirectory(${impl})
-
- list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:mac_ghash_${impl}>)
-endforeach(impl)
-
-
-set(MAC_NAME "ghash" PARENT_SCOPE)
-set(IMPLS "${IMPLS}" PARENT_SCOPE)
-set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)
+fastd_mac(ghash)
+add_subdirectory(builtin)