summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-25 02:19:32 +0200
commit9bf498263765328011ee105e5e7b3e1cc1b2bc3f (patch)
treea6e18dfd838633e7444ae5deab8fc2b130780ec2 /src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
parentf2d84afd9d8373bf2778d1a1635384000c03f887 (diff)
downloadfastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.tar
fastd-9bf498263765328011ee105e5e7b3e1cc1b2bc3f.zip
Experimental HMAC-SHA1 implementation
This adds experimental support for <cipher>+hmac-sha1 methods. It currently depends on OpenSSL and is not yet ready for production use.
Diffstat (limited to 'src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt b/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
new file mode 100644
index 0000000..cb08c58
--- /dev/null
+++ b/src/crypto/mac/hmac_sha1/openssl/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(ENABLE_OPENSSL)
+ fastd_mac_impl(hmac-sha1 openssl
+ hmac_sha1_openssl.c
+ )
+ fastd_cipher_impl_include_directories(hmac-sha1 openssl ${OPENSSL_INCLUDE_DIRS})
+endif(ENABLE_OPENSSL)