summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-07 18:09:32 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-07 18:09:32 +0100
commit2fb08c6455bf6f08209b5993c755c1135611813b (patch)
treef604b15b0d84cafb37684cacad4dd4d74ab2d8c6 /src/methods/CMakeLists.txt
parentd971fce38b72c935b58e149ab1f8eb92202e76db (diff)
downloadfastd-2fb08c6455bf6f08209b5993c755c1135611813b.tar
fastd-2fb08c6455bf6f08209b5993c755c1135611813b.zip
CMake: add LINK_LIBRARIES workaround for old CMake versions
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
index 3d1e2e2..e515b32 100644
--- a/src/methods/CMakeLists.txt
+++ b/src/methods/CMakeLists.txt
@@ -38,4 +38,7 @@ foreach(method ${METHODS})
set(METHOD_LIST "${METHOD_LIST}\n&fastd_method_${method_},")
endforeach(method)
+get_property(LIBS TARGET methods PROPERTY FASTD_LINK_LIBRARIES)
+target_link_libraries(methods ${LIBS})
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/methods.c.in ${CMAKE_CURRENT_BINARY_DIR}/methods.c)