summaryrefslogtreecommitdiffstats
path: root/src/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-08-28 18:46:02 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-08-28 18:46:02 +0200
commit46a82c570cf940479be968864eb9638407d7d84f (patch)
tree26fdb9aeaf7cc04a97dfd9470ad24c8053b19e3e /src/methods/CMakeLists.txt
parenta681219a9275ded66dd927750edcec7859cbffbb (diff)
downloadfastd-46a82c570cf940479be968864eb9638407d7d84f.tar
fastd-46a82c570cf940479be968864eb9638407d7d84f.zip
Add generic-umac and composed-umac methods based on UMAC
Diffstat (limited to 'src/methods/CMakeLists.txt')
-rw-r--r--src/methods/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/methods/CMakeLists.txt b/src/methods/CMakeLists.txt
index f83f7b4..845734d 100644
--- a/src/methods/CMakeLists.txt
+++ b/src/methods/CMakeLists.txt
@@ -25,8 +25,10 @@ endmacro(fastd_method_require)
add_subdirectory(null)
add_subdirectory(cipher_test)
add_subdirectory(composed_gmac)
+add_subdirectory(composed_umac)
add_subdirectory(generic_gmac)
add_subdirectory(generic_poly1305)
+add_subdirectory(generic_umac)
add_subdirectory(xsalsa20_poly1305)