summaryrefslogtreecommitdiffstats
path: root/src/protocols/ec25519_fhmqvc/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 16:59:42 +0100
commit095ca93d81cfae0fcb137919231810577c556404 (patch)
treea5ee059d61dd5c0483657105fb2f5400350f3150 /src/protocols/ec25519_fhmqvc/CMakeLists.txt
parent5f6177e00fe4c56ece2cabdd61b772ed040c6e19 (diff)
downloadfastd-095ca93d81cfae0fcb137919231810577c556404.tar
fastd-095ca93d81cfae0fcb137919231810577c556404.zip
Organize method and protocol source files into distinct source directories
Diffstat (limited to 'src/protocols/ec25519_fhmqvc/CMakeLists.txt')
-rw-r--r--src/protocols/ec25519_fhmqvc/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/protocols/ec25519_fhmqvc/CMakeLists.txt b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
new file mode 100644
index 0000000..ff1e246
--- /dev/null
+++ b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories(BEFORE ${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${UECC_INCLUDE_DIRS})
+
+add_library(protocol_ec25519_fhmqvc OBJECT
+ ec25519_fhmqvc.c
+)
+set_property(TARGET protocol_ec25519_fhmqvc PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")