summaryrefslogtreecommitdiffstats
path: root/src/protocols/ec25519_fhmqvc/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-30 19:46:43 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-30 19:46:43 +0100
commit19bdfda6a2975ab71cd30058a34fb48cb3eee562 (patch)
tree807871b12d8879bcaa8d880d1b9169fab31d8588 /src/protocols/ec25519_fhmqvc/CMakeLists.txt
parent641422da88f060c9dbe846f8fa2c64a41e4c4e48 (diff)
downloadfastd-19bdfda6a2975ab71cd30058a34fb48cb3eee562.tar
fastd-19bdfda6a2975ab71cd30058a34fb48cb3eee562.zip
Separate ec25519-fhmqvc into multiple source files
Diffstat (limited to 'src/protocols/ec25519_fhmqvc/CMakeLists.txt')
-rw-r--r--src/protocols/ec25519_fhmqvc/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/protocols/ec25519_fhmqvc/CMakeLists.txt b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
index 91d6eaa..48d2ef4 100644
--- a/src/protocols/ec25519_fhmqvc/CMakeLists.txt
+++ b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
@@ -2,5 +2,8 @@ include_directories(${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${UECC_INCLUDE_D
add_library(protocol_ec25519_fhmqvc OBJECT
ec25519_fhmqvc.c
+ handshake.c
+ state.c
+ util.c
)
set_property(TARGET protocol_ec25519_fhmqvc PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")