summaryrefslogtreecommitdiffstats
path: root/src/protocols/ec25519_fhmqvc/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-29 03:45:34 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-29 03:45:34 +0100
commitbb324029ad442a1f6dd7049a6e6fc1cbe4a05799 (patch)
treee3f3e7c33a8077ba5bc721009dd71ea8644f1c1d /src/protocols/ec25519_fhmqvc/CMakeLists.txt
parentfc8c8d82f05911836208cc9169e103d5578ffd70 (diff)
downloadfastd-bb324029ad442a1f6dd7049a6e6fc1cbe4a05799.tar
fastd-bb324029ad442a1f6dd7049a6e6fc1cbe4a05799.zip
Allow using libsodium instead of NaCl
As libsodium has some strange include files (like a version.h), we try to use absolute include paths whenever possible in fastd now and rename our generated headers.
Diffstat (limited to 'src/protocols/ec25519_fhmqvc/CMakeLists.txt')
-rw-r--r--src/protocols/ec25519_fhmqvc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/protocols/ec25519_fhmqvc/CMakeLists.txt b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
index ff1e246..91d6eaa 100644
--- a/src/protocols/ec25519_fhmqvc/CMakeLists.txt
+++ b/src/protocols/ec25519_fhmqvc/CMakeLists.txt
@@ -1,4 +1,4 @@
-include_directories(BEFORE ${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${UECC_INCLUDE_DIRS})
+include_directories(${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${UECC_INCLUDE_DIRS})
add_library(protocol_ec25519_fhmqvc OBJECT
ec25519_fhmqvc.c