summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 84f25fe..ea1e8c9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,6 +24,7 @@ add_executable(fastd
${BISON_fastd_config_parse_OUTPUTS}
${METHODS}
)
-target_link_libraries(fastd rt ${CMAKE_THREAD_LIBS_INIT} ${UECC_LIBRARY} ${NACL_LIBRARY})
+set_target_properties(fastd PROPERTIES COMPILE_FLAGS -pthread LINK_FLAGS -pthread)
+target_link_libraries(fastd rt ${UECC_LIBRARY} ${NACL_LIBRARY})
install(TARGETS fastd RUNTIME DESTINATION sbin)