summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crypto/cipher/aes128_ctr/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
new file mode 100644
index 0000000..6237a7c
--- /dev/null
+++ b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(IMPLS "")
+
+if(WITH_CIPHER_AES128_CTR_NACL)
+ list(APPEND IMPLS nacl)
+endif(WITH_CIPHER_AES128_CTR_NACL)
+
+set(IMPL_SOURCES "")
+
+foreach(impl ${IMPLS})
+ add_subdirectory(${impl})
+
+ list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:cipher_aes128_ctr_${impl}>)
+endforeach(impl)
+
+
+set(CIPHER_NAME "aes128-ctr" PARENT_SCOPE)
+set(IMPLS "${IMPLS}" PARENT_SCOPE)
+set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)