summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
new file mode 100644
index 0000000..5454b3f
--- /dev/null
+++ b/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(USE_OPENSSL)
+ fastd_cipher_impl(aes128-ctr openssl
+ aes128_ctr_openssl.c
+ )
+ fastd_cipher_impl_include_directories(aes128-ctr openssl ${OPENSSL_INCLUDE_DIRS})
+endif(USE_OPENSSL)