summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt b/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
new file mode 100644
index 0000000..76bce41
--- /dev/null
+++ b/src/crypto/cipher/blowfish_ctr/openssl/CMakeLists.txt
@@ -0,0 +1,7 @@
+if(USE_OPENSSL)
+ fastd_cipher_impl(blowfish-ctr openssl
+ blowfish_ctr.c
+ )
+ fastd_cipher_impl_include_directories(blowfish-ctr openssl ${OPENSSL_INCLUDE_DIRS})
+ fastd_cipher_impl_link_libraries(blowfish-ctr openssl ${OPENSSL_CRYPTO_LIBRARIES})
+endif(USE_OPENSSL)