summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/salsa20/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/salsa20/nacl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/salsa20/nacl/CMakeLists.txt b/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
new file mode 100644
index 0000000..d76ff34
--- /dev/null
+++ b/src/crypto/cipher/salsa20/nacl/CMakeLists.txt
@@ -0,0 +1,6 @@
+fastd_cipher_impl(salsa20 nacl
+ salsa20_nacl.c
+)
+fastd_cipher_impl_include_directories(salsa20 nacl ${NACL_INCLUDE_DIRS})
+fastd_cipher_impl_link_libraries(salsa20 nacl ${NACL_LIBRARIES})
+fastd_cipher_impl_require(salsa20 nacl NACL)