summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/salsa2012/xmm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/cipher/salsa2012/xmm/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/salsa2012/xmm/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/crypto/cipher/salsa2012/xmm/CMakeLists.txt b/src/crypto/cipher/salsa2012/xmm/CMakeLists.txt
new file mode 100644
index 0000000..9cb5222
--- /dev/null
+++ b/src/crypto/cipher/salsa2012/xmm/CMakeLists.txt
@@ -0,0 +1,13 @@
+if(ARCH_X86_64)
+ fastd_cipher_impl(salsa2012 xmm
+ salsa2012_xmm.c
+ salsa2012_amd64_xmm6.s
+ )
+endif(ARCH_X86_64)
+
+if(ARCH_X86)
+ fastd_cipher_impl(salsa2012 xmm
+ salsa2012_xmm.c
+ salsa2012_x86_xmm5.s
+ )
+endif(ARCH_X86)