summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/mac/CMakeLists.txt')
-rw-r--r--src/crypto/mac/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/crypto/mac/CMakeLists.txt b/src/crypto/mac/CMakeLists.txt
index fe13ace..ca3b71d 100644
--- a/src/crypto/mac/CMakeLists.txt
+++ b/src/crypto/mac/CMakeLists.txt
@@ -58,7 +58,9 @@ foreach(mac ${MACS})
endforeach(impl)
set(MAC_IMPLS "${MAC_IMPLS}NULL};")
-
endforeach(mac)
+get_property(LIBS TARGET macs PROPERTY FASTD_LINK_LIBRARIES)
+target_link_libraries(macs ${LIBS})
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/macs.c.in ${CMAKE_CURRENT_BINARY_DIR}/macs.c)