summaryrefslogtreecommitdiffstats
path: root/src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt')
-rw-r--r--src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt b/src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt
index 59bc09d..f96f680 100644
--- a/src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt
+++ b/src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt
@@ -1,11 +1,11 @@
if(ARCH_X86 OR ARCH_X86_64)
- if(NOT HAVE_PCLMUL)
- message(FATAL_ERROR "WITH_MAC_GHASH_PCLMULQDQ enabled, but there is no compiler support for -mpclmul")
- endif(NOT HAVE_PCLMUL)
-
fastd_mac_impl(ghash pclmulqdq
ghash_pclmulqdq.c
ghash_pclmulqdq_impl.c
)
fastd_mac_impl_compile_flags(ghash pclmulqdq ghash_pclmulqdq_impl.c "-mssse3 -mpclmul")
+
+ if(WITH_MAC_GHASH_PCLMULQDQ AND NOT HAVE_PCLMUL)
+ message(FATAL_ERROR "WITH_MAC_GHASH_PCLMULQDQ enabled, but there is no compiler support for -mpclmul")
+ endif(WITH_MAC_GHASH_PCLMULQDQ AND NOT HAVE_PCLMUL)
endif(ARCH_X86 OR ARCH_X86_64)