summaryrefslogtreecommitdiffstats
path: root/src/methods/aes128_gcm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/methods/aes128_gcm/CMakeLists.txt')
-rw-r--r--src/methods/aes128_gcm/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/methods/aes128_gcm/CMakeLists.txt b/src/methods/aes128_gcm/CMakeLists.txt
new file mode 100644
index 0000000..1c5aa3f
--- /dev/null
+++ b/src/methods/aes128_gcm/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories(BEFORE ${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${NACL_INCLUDE_DIR})
+
+add_library(method_aes128_gcm OBJECT
+ aes128_gcm.c
+)
+set_property(TARGET method_aes128_gcm PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")