summaryrefslogtreecommitdiffstats
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
new file mode 100644
index 0000000..f033d32
--- /dev/null
+++ b/src/protocols/CMakeLists.txt
@@ -0,0 +1,10 @@
+set(PROTOCOLS ec25519_fhmqvc)
+
+set(PROTOCOL_OBJECTS "")
+
+foreach(protocol ${PROTOCOLS})
+ add_subdirectory(${protocol})
+ list(APPEND PROTOCOL_OBJECTS $<TARGET_OBJECTS:protocol_${protocol}>)
+endforeach(protocol)
+
+set(PROTOCOL_OBJECTS "${PROTOCOL_OBJECTS}" PARENT_SCOPE)