summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-06-25 17:43:59 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-06-25 17:43:59 +0200
commitec6a1303a20d414b726fd883c9f597723e5e3c17 (patch)
tree0c18d47d4e15e0f5b7bf4aae1df18db723315e13 /CMakeLists.txt
downloadlibuaes-ec6a1303a20d414b726fd883c9f597723e5e3c17.tar
libuaes-ec6a1303a20d414b726fd883c9f597723e5e3c17.zip
Create build filesHEADmaster
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..75f166b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,9 @@
+cmake_minimum_required(VERSION 2.6)
+project(LIBUAES C)
+
+set(CMAKE_MODULE_PATH ${LIBUAES_SOURCE_DIR})
+
+add_subdirectory(src)
+
+FILE(GLOB include_files "${CMAKE_CURRENT_SOURCE_DIR}/include/libuaes/*.h")
+install(FILES ${include_files} DESTINATION include/libuaes)