summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-12-26 06:01:01 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-12-26 06:01:01 +0100
commitf2ca23547efcb8ffbc0dd22f4daba1f7ce2c0260 (patch)
treeaa4a78832244139a22c6e2a2bbed8e56bad9e506 /CMakeLists.txt
parent85aa5199d21d5b973c54672ee3e20a592f605d00 (diff)
downloadlibuecc-f2ca23547efcb8ffbc0dd22f4daba1f7ce2c0260.tar
libuecc-f2ca23547efcb8ffbc0dd22f4daba1f7ce2c0260.zip
Use LIB_SUFFIX in pkg-config information
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ac0e20..9cd7406 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,10 +9,12 @@ set(DOXYFILE_EXTRA_SOURCES "${CMAKE_CURRENT_SOURCE_DIR}/include")
include(UseDoxygen OPTIONAL)
+set(LIBDIR "lib${LIB_SUFFIX}")
+
add_subdirectory(src)
configure_file(${LIBUECC_SOURCE_DIR}/libuecc.pc.in ${LIBUECC_BINARY_DIR}/libuecc.pc @ONLY)
-install(FILES ${LIBUECC_BINARY_DIR}/libuecc.pc DESTINATION "lib/pkgconfig")
+install(FILES ${LIBUECC_BINARY_DIR}/libuecc.pc DESTINATION "${LIBDIR}/pkgconfig")
FILE(GLOB include_files "${CMAKE_CURRENT_SOURCE_DIR}/include/libuecc/*.h")
install(FILES ${include_files} DESTINATION "include/libuecc-${PROJECT_VERSION}/libuecc")