summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d859809..729ff76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,12 +4,17 @@ project(MAD)
set(CMAKE_MODULE_PATH ${MAD_SOURCE_DIR})
find_package(LibXml2 REQUIRED)
-find_package(Readline REQUIRED)
find_package(OpenSSL REQUIRED)
find_package(Boost REQUIRED date_time filesystem regex signals system thread)
find_package(MySQL)
find_package(KRB5 COMPONENTS krb5 kadm-client)
+find_package(Editline)
+if(NOT EDITLINE_FOUND)
+ find_package(Readline REQUIRED)
+ set(EDITLINE_LIBRARY ${READLINE_LIBRARY})
+endif(NOT EDITLINE_FOUND)
+
if(WIN32)
add_definitions(-DWINVER=0x0501 -D_WIN32_WINNT=0x0501)