summaryrefslogtreecommitdiffstats
path: root/src/Net/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Net/CMakeLists.txt')
-rw-r--r--src/Net/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Net/CMakeLists.txt b/src/Net/CMakeLists.txt
new file mode 100644
index 0000000..aa3f857
--- /dev/null
+++ b/src/Net/CMakeLists.txt
@@ -0,0 +1,8 @@
+include_directories(${INCLUDES})
+link_directories(${Boost_LIBRARY_DIRS})
+
+add_library(Net
+ ClientConnection.cpp Connection.cpp Exception.cpp FdManager.cpp IPAddress.cpp
+ Listener.cpp Packet.cpp ServerConnection.cpp ThreadManager.cpp
+)
+target_link_libraries(Net ${Boost_LIBRARIES} ${GNUTLS_LIBRARIES})