summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b03ef7..b090659 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,9 @@
-lib_LTLIBRARIES = libneofx.la
-libneofx_la_SOURCES = math.c collision.c physics.c
-nobase_include_HEADERS = neofx/math.h neofx/collision.h neofx/types.h neofx/physics.h
+lib_LTLIBRARIES = libneofx.la
+libneofx_la_SOURCES = math.c collision.c physics.c
+libneofx_la_LDFLAGS = -version-info 0:0:0 -release 0.1
+
+library_includedir = $(includedir)/libneofx-0.1/neofx
+library_include_HEADERS = neofx/math.h neofx/collision.h neofx/types.h neofx/physics.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libneofx-0.1.pc