summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 613b87c..c175a8e 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,7 @@ AC_PROG_CC
AC_PROG_LIBTOOL
# Checks for libraries.
+AC_CHECK_LIB(m, [sqrt])
# Checks for header files.
AC_HEADER_STDC
@@ -25,8 +26,8 @@ AC_HEADER_TIME
# Checks for library functions.
AC_FUNC_MALLOC
AC_FUNC_REALLOC
-AC_CHECK_LIB(m, [cos])
-AC_CHECK_FUNCS([sqrt], , AC_MSG_ERROR([required function sqrt not found]))
+
+AC_CHECK_FUNCS([sqrtf], , AC_MSG_ERROR([required function sqrtf not found]))
AC_CONFIG_FILES([Makefile])
AC_OUTPUT