summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..aecff14
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,27 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(zoom, 0.1, matthias@gamezock.de)
+AC_CONFIG_SRCDIR([zoom-bin.c])
+AC_CONFIG_HEADER([config.h])
+
+AM_INIT_AUTOMAKE
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+AC_CHECK_LIB([zoom], [Render], , AC_MSG_ERROR([libzoom not found]))
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_CHECK_FUNCS([gettimeofday])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT