summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-09-19 09:04:21 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-09-19 09:04:21 +0200
commit8fac573efcb64e8db7416b3b117f05e7032a7c74 (patch)
tree8e17fe4aea7038da79d4c2c57cf302cc3214c13e /CMakeLists.txt
downloadulock-8fac573efcb64e8db7416b3b117f05e7032a7c74.tar
ulock-8fac573efcb64e8db7416b3b117f05e7032a7c74.zip
Set up build system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..14fab01
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(ULOCK C)
+cmake_minimum_required(VERSION 2.8)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(GTK3 REQUIRED gtk+-x11-3.0)
+
+include_directories(${GTK3_INCLUDE_DIRS})
+
+add_executable(ulock ulock.c)
+set_property(TARGET ulock PROPERTY COMPILE_FLAGS "-Wall ${GTK3_CFLAGS_OTHER}")
+set_property(TARGET ulock PROPERTY LINK_FLAGS "${GTK3_LDFLAGS_OTHER}")
+target_link_libraries(ulock ${GTK3_LIBRARIES})