summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 89cf970..ec2417b 100644
--- a/configure.in
+++ b/configure.in
@@ -123,6 +123,10 @@ else
;;
ipv4:freebsd*) sysdesc=bsd
;;
+ ipv6:kfreebsd*) sysdesc=bsd-v6
+ ;;
+ ipv4:kfreebsd*) sysdesc=bsd
+ ;;
ipv6:openbsd*) sysdesc=bsd-v6
;;
ipv4:openbsd*) sysdesc=bsd
@@ -177,8 +181,10 @@ AC_TRY_COMPILE([#include <sys/types.h>
AC_DEFINE(HAVE_SIN_LEN,,sin_len)],
AC_MSG_RESULT(no))
+AC_C_BIGENDIAN([AC_DEFINE(CPU_BIG_ENDIAN)], [AC_DEFINE(CPU_LITTLE_ENDIAN)],
+ [AC_MSG_ERROR([Cannot determine CPU endianity.])])
+
BIRD_CHECK_INTEGERS
-BIRD_CHECK_ENDIAN
BIRD_CHECK_STRUCT_ALIGN
BIRD_CHECK_TIME_T
BIRD_CHECK_STRUCT_IP_MREQN