summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 939f542..1f3f5df 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,6 +1,12 @@
-add_definitions(${GTK_CFLAGS} ${GTK_CFLAGS_OTHER} ${GEE_CFLAGS} ${GEE_CFLAGS_OTHER} ${ERL_CFLAGS} ${ERL_CFLAGS_OTHER})
-link_libraries(${GTK_LIBRARIES} ${ERL_LIBRARIES} ${GEE_LIBRARIES})
-link_directories(${GTK_LIBRARY_DIRS} ${ERL_LIBRARY_DIRS} ${GEE_LIBRARY_DIRS})
+add_definitions(
+ ${GTK_CFLAGS} ${GTK_CFLAGS_OTHER}
+ ${GEE_CFLAGS} ${GEE_CFLAGS_OTHER}
+ ${GIO_CFLAGS} ${GIO_CFLAGS_OTHER}
+ ${GIO_UNIX_CFLAGS} ${GIO_UNIX_CFLAGS_OTHER}
+ ${EVA_CFLAGS} ${EVA_CFLAGS_OTHER}
+)
+link_libraries(${GTK_LIBRARIES} ${GEE_LIBRARIES} ${GIO_LIBRARIES} ${GIO_UNIX_LIBRARIES} ${EVA_LIBRARIES})
+link_directories(${GTK_LIBRARY_DIRS} ${GEE_LIBRARY_DIRS} ${GIO_LIBRARY_DIRS} ${GIO_UNIX_LIBRARY_DIRS} ${EVA_LIBRARY_DIRS})
add_subdirectory(core ${ephraim_BINARY_DIR}/core)
add_subdirectory(gui ${ephraim_BINARY_DIR}/gui)