summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2010-07-07 05:24:31 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2010-07-07 05:24:31 +0200
commit712b073f95f694f23a070bd43cd0c9e7479142b7 (patch)
tree82eaa888eac197da5a772f4bb88a1be6b7bdba63 /CMakeLists.txt
parenta6a3c416c77d383f00a723ceb4545e89a2334923 (diff)
downloadeva-712b073f95f694f23a070bd43cd0c9e7479142b7.tar
eva-712b073f95f694f23a070bd43cd0c9e7479142b7.zip
Implemented most types, sending & receiving
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9dddf9a..844570d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,11 +11,9 @@ ensure_vala_version("0.8" MINIMUM)
find_package(PkgConfig)
pkg_check_modules(GEE REQUIRED gee-1.0)
+pkg_check_modules(GIO REQUIRED gio-2.0)
+pkg_check_modules(GIO_UNIX REQUIRED gio-unix-2.0)
pkg_check_modules(ERL REQUIRED erl_interface)
-add_definitions(${GEE_CFLAGS} ${GEE_CFLAGS_OTHER} ${ERL_CFLAGS} ${ERL_CFLAGS_OTHER})
-link_libraries(${GEE_LIBRARIES} ${ERL_LIBRARIES})
-link_directories(${GEE_LIBRARY_DIRS} ${ERL_LIBRARY_DIRS})
-
add_subdirectory(src)
add_subdirectory(test)