summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 14:34:01 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 14:34:01 +0100
commit20a95ef2731ce21acfe5c1ba97b40001217b0216 (patch)
treea41ed017d615a42771113fc9d7ee3df67652620f /CMakeLists.txt
parent7a3c8bee42879add84a143ff98f28cbd0251dc7b (diff)
downloadfastd-20a95ef2731ce21acfe5c1ba97b40001217b0216.tar
fastd-20a95ef2731ce21acfe5c1ba97b40001217b0216.zip
Convert aes128-gcm into a generic gcm method
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 371530b..12daafa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,7 +36,7 @@ set(WITH_CIPHER_AES128_CTR_NACL TRUE CACHE BOOL "Include the AES128-CTR implemen
set(WITH_CRYPTO_GHASH_BUILTIN TRUE CACHE BOOL "Include the built-in GHASH implementation")
set(WITH_METHOD_XSALSA20_POLY1305 TRUE CACHE BOOL "Include xsalsa20-poly1305 method")
-set(WITH_METHOD_AES128_GCM TRUE CACHE BOOL "Include aes128-gcm method")
+set(WITH_METHOD_GENERIC_GCM TRUE CACHE BOOL "Include generic gcm method")
set(USE_LIBSODIUM FALSE CACHE BOOL "Use libsodium instead of NaCl")