summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-08-11 19:49:33 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-08-11 19:49:33 +0200
commit3831c232a80ca178b547c4f5db9b5b5d3182640e (patch)
treea5c48bdcd98c775d6ebb1e8c801a9e7950911d95 /CMakeLists.txt
parentfe344be938fb5d4644553a6886f6455fa337ce72 (diff)
downloadfastd-3831c232a80ca178b547c4f5db9b5b5d3182640e.tar
fastd-3831c232a80ca178b547c4f5db9b5b5d3182640e.zip
Fix librt check
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a98adb..f7160eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,12 +52,12 @@ check_symbol_exists("clock_gettime" "time.h" HAVE_CLOCK_GETTIME)
if(NOT HAVE_CLOCK_GETTIME)
set(RT_LIBRARY "rt")
- list(append CMAKE_REQUIRED_LIBRARIES "rt")
+ list(APPEND CMAKE_REQUIRED_LIBRARIES "rt")
- check_symbol_exists("clock_gettime" "time.h" HAVE_CLOCK_GETTIME)
- if(NOT HAVE_CLOCK_GETTIME)
+ check_symbol_exists("clock_gettime" "time.h" HAVE_CLOCK_GETTIME_RT)
+ if(NOT HAVE_CLOCK_GETTIME_RT)
message(FATAL_ERROR "clock_gettime() not found")
- endif(NOT HAVE_CLOCK_GETTIME)
+ endif(NOT HAVE_CLOCK_GETTIME_RT)
endif(NOT HAVE_CLOCK_GETTIME)