summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-08-08 23:45:36 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-08-08 23:45:36 +0200
commitca354d9e2e6cddb698f727b282c22c1f4a7a3cf5 (patch)
treee966ea5f6f8a1a4cc8b7296f3820ebcd5048a019 /CMakeLists.txt
parent16ca5451aa45e90fdefd2cc6480f7b9e31066b37 (diff)
downloadfastd-ca354d9e2e6cddb698f727b282c22c1f4a7a3cf5.tar
fastd-ca354d9e2e6cddb698f727b282c22c1f4a7a3cf5.zip
Check for AI_ADDRCONFIG
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9c76d5..0fa9d72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,17 +26,27 @@ else()
endif()
+include(CheckCSourceCompiles)
include(CheckPrototypeDefinition)
include(CheckTypeSize)
set(CMAKE_EXTRA_INCLUDE_FILES "netinet/if_ether.h")
set(CMAKE_REQUIRED_DEFINITIONS "-D_GNU_SOURCE")
+check_c_source_compiles("
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netdb.h>
+
+int main() {
+ return AI_ADDRCONFIG;
+}
+" HAVE_AI_ADDRCONFIG)
+
check_prototype_definition("get_current_dir_name" "char *get_current_dir_name(void)" "NULL" "unistd.h" HAVE_GET_CURRENT_DIR_NAME)
check_type_size("struct ethhdr" SIZEOF_ETHHDR)
string(COMPARE NOTEQUAL "${SIZEOF_ETHHDR}" "" HAVE_ETHHDR)
-
set(USE_BINDTODEVICE ${LINUX})
set(USE_PMTU ${LINUX})
set(USE_PKTINFO ${LINUX})