summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-08-14 19:12:45 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-08-14 19:12:45 +0200
commite10944f8c9b774ad4e8c618bea7962d31756b4ad (patch)
tree618bdd3cdaf2f1843db914f0b4bc21486bd024b5 /CMakeLists.txt
parent5ebebb3688a0e88fadc6a10219572cbcf3a8603a (diff)
downloadfastd-e10944f8c9b774ad4e8c618bea7962d31756b4ad.tar
fastd-e10944f8c9b774ad4e8c618bea7962d31756b4ad.zip
Allow disabling redundant command line options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de04693..b260f77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,11 @@ set(USE_PKTINFO ${LINUX})
set(WITH_CAPABILITIES ${LINUX} CACHE BOOL "Include support for POSIX capabilities")
+set(WITH_CMDLINE_USER TRUE CACHE BOOL "Include support for setting user/group related options on the command line")
+set(WITH_CMDLINE_LOGGING TRUE CACHE BOOL "Include support for setting logging related options on the command line")
+set(WITH_CMDLINE_OPERATION TRUE CACHE BOOL "Include support for setting options related to the VPN operation (like mode, interface, encryption method) on the command line")
+set(WITH_CMDLINE_COMMANDS TRUE CACHE BOOL "Include support for setting handler scripts (e.g. --on-up) on the command line")
+
if(WITH_CAPABILITIES)
find_package(CAP REQUIRED)