summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-10-20 23:10:09 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-10-20 23:10:09 +0200
commit11bca5a7af4b448ee0a37cd243e34ecd0e652b3d (patch)
tree04a51ccec3f2db4d16591698c76c4c56b893ec1b /src/CMakeLists.txt
parent64d0bef9efd4a82b7a132b490328c80e67431041 (diff)
downloadfastd-11bca5a7af4b448ee0a37cd243e34ecd0e652b3d.tar
fastd-11bca5a7af4b448ee0a37cd243e34ecd0e652b3d.zip
Improve include_directories to prevent conflicts between system and fastd headers
In in-tree builds, fastd's poll.h was conflicting with the system one on non-Linux systems.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 20813ce..086e23d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,7 +1,7 @@
set_property(DIRECTORY PROPERTY COMPILE_DEFINITIONS _GNU_SOURCE __APPLE_USE_RFC_3542)
set(FASTD_CFLAGS "${PTHREAD_CFLAGS} -std=c99 ${LIBUECC_CFLAGS_OTHER} ${LIBNACL_CFLAGS_OTHER} ${JSON_C_CFLAGS_OTHER} ${CFLAGS_LTO} -Wall")
-include_directories(${FASTD_SOURCE_DIR} ${FASTD_BINARY_DIR}/src)
+include_directories(${FASTD_SOURCE_DIR} ${FASTD_BINARY_DIR}/gen)
include(generate_version)
@@ -12,9 +12,9 @@ add_subdirectory(methods)
add_subdirectory(crypto)
include(check_reqs)
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/fastd_config.h.in ${CMAKE_CURRENT_BINARY_DIR}/fastd_config.h)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/build.h.in ${CMAKE_BINARY_DIR}/gen/generated/build.h)
-BISON_TARGET(fastd_config_parse config.y ${CMAKE_CURRENT_BINARY_DIR}/config.yy.c)
+BISON_TARGET(fastd_config_parse config.y ${CMAKE_BINARY_DIR}/gen/generated/config.yy.c)
add_executable(fastd
android.c