summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-09-15 07:25:56 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-09-15 07:25:56 +0200
commit541ee8295e0fe1b7c51fa4aee74aaa12f696860b (patch)
treee0df9c0989500ed2089b64004ac337ebc4dcc97e /src/CMakeLists.txt
parent37385fcd836bcc086b56b8dc7089d5038c203f13 (diff)
downloadfastd-541ee8295e0fe1b7c51fa4aee74aaa12f696860b.tar
fastd-541ee8295e0fe1b7c51fa4aee74aaa12f696860b.zip
Add support for using kernel implementations of GHASH
This doesn't really improve performance on my Intel CPU (I guess due to the context switches), but more tests have to be made, in combination with offloading the AES to the kernel as well, and on different hardware.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 29e3ba5..61dcbc6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -17,6 +17,7 @@ add_executable(fastd
fastd.c
config.c
handshake.c
+ linux_alg.c
peer.c
printf.c
queue.c