summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-04-16 05:23:12 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-04-16 05:23:12 +0200
commit96ec41768b5937e5cf0cd83bf815d365d12d1f93 (patch)
treec56fb1c45db75c32b156b5ceee8758334df69c12 /src/CMakeLists.txt
parent037c58ae51a61064d7bb5022715546509328d83f (diff)
downloadfastd-96ec41768b5937e5cf0cd83bf815d365d12d1f93.tar
fastd-96ec41768b5937e5cf0cd83bf815d365d12d1f93.zip
Add support for peers specified by hostnames
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a700c4c..84f25fe 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -17,12 +17,13 @@ add_executable(fastd
printf.c
queue.c
random.c
+ resolve.c
task.c
protocol_ec25519_fhmqvc.c
${FLEX_fastd_config_lex_OUTPUTS}
${BISON_fastd_config_parse_OUTPUTS}
${METHODS}
)
-target_link_libraries(fastd rt ${UECC_LIBRARY} ${NACL_LIBRARY})
+target_link_libraries(fastd rt ${CMAKE_THREAD_LIBS_INIT} ${UECC_LIBRARY} ${NACL_LIBRARY})
install(TARGETS fastd RUNTIME DESTINATION sbin)