summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 11:12:42 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 11:12:42 +0100
commitb117a60e81c3d67880cd8b0079041c92a0818d96 (patch)
tree8db87c3e0710ce5b2201d7734a93dd3024631b1c /src/CMakeLists.txt
parent7fe38b0200979c15cc27a84ab51b2730e7f2d30e (diff)
downloadfastd-b117a60e81c3d67880cd8b0079041c92a0818d96.tar
fastd-b117a60e81c3d67880cd8b0079041c92a0818d96.zip
Allow building without NaCl again
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 361b546..6c882b7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,14 +6,14 @@ link_directories(${UECC_LIBRARY_DIRS} ${NACL_LIBRARY_DIRS})
include(generate_version)
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/fastd_config.h.in ${CMAKE_CURRENT_BINARY_DIR}/fastd_config.h)
-
include(fastd_module)
add_subdirectory(protocols)
add_subdirectory(methods)
add_subdirectory(crypto)
+include(check_reqs)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/fastd_config.h.in ${CMAKE_CURRENT_BINARY_DIR}/fastd_config.h)
BISON_TARGET(fastd_config_parse config.y ${CMAKE_CURRENT_BINARY_DIR}/config.yy.c)