summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-08-07 00:51:21 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-08-07 00:51:21 +0200
commitc850180a471fdc88213153549b834cffd0c19937 (patch)
tree76b6777a8d2296e76602b63155e1337fe6682b28 /src/CMakeLists.txt
parent3467e5133a4e9e62f84d02012ed3b4d54d50181f (diff)
downloadfastd-c850180a471fdc88213153549b834cffd0c19937.tar
fastd-c850180a471fdc88213153549b834cffd0c19937.zip
Move _GNU_SOURCE definition to CMake
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cd0b5b5..980fc52 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -37,7 +37,7 @@ add_executable(fastd
${BISON_fastd_config_parse_OUTPUTS}
${METHODS}
)
-set_target_properties(fastd PROPERTIES COMPILE_FLAGS -pthread ${UECC_CFLAGS_OTHER} LINK_FLAGS -pthread ${UECC_LDFLAGS_OTHER})
+set_target_properties(fastd PROPERTIES COMPILE_FLAGS -pthread ${UECC_CFLAGS_OTHER} COMPILE_DEFINITIONS _GNU_SOURCE LINK_FLAGS -pthread ${UECC_LDFLAGS_OTHER})
target_link_libraries(fastd rt ${CAP_LIBRARY} ${UECC_LIBRARIES} ${NACL_LIBRARY})
add_custom_target(