summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 02:20:09 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-03 02:20:09 +0100
commite7893cc54fb0eaba0cfe88ff44cf52a3f7ff2200 (patch)
treee8036848eae496deea839ec35389d710b54cd18c /src/CMakeLists.txt
parentd04123c9ed17d7a590702cd574e651aa78021a5c (diff)
downloadfastd-e7893cc54fb0eaba0cfe88ff44cf52a3f7ff2200.tar
fastd-e7893cc54fb0eaba0cfe88ff44cf52a3f7ff2200.zip
Even nicer method specification
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 286d3d7..e5c900f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,7 @@ include(generate_version)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/fastd_config.h.in ${CMAKE_CURRENT_BINARY_DIR}/fastd_config.h)
+include(fastd_module)
add_subdirectory(protocols)
add_subdirectory(methods)
add_subdirectory(crypto)
@@ -36,13 +37,12 @@ add_executable(fastd
tuntap.c
${BISON_fastd_config_parse_OUTPUTS}
${PROTOCOL_SOURCES}
- ${METHOD_SOURCES}
${CRYPTO_SOURCES}
)
set_property(TARGET fastd PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")
set_property(TARGET fastd PROPERTY LINK_FLAGS "-pthread ${UECC_LDFLAGS_OTHER} ${NACL_LDFLAGS_OTHER}")
target_include_directories(fastd PRIVATE ${CAP_INCLUDE_DIR} ${NACL_INCLUDE_DIRS})
-target_link_libraries(fastd ${RT_LIBRARY} ${CAP_LIBRARY} ${UECC_LIBRARIES} ${NACL_LIBRARIES})
+target_link_libraries(fastd methods ${RT_LIBRARY} ${CAP_LIBRARY} ${UECC_LIBRARIES} ${NACL_LIBRARIES})
add_dependencies(fastd version)