summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 04:32:18 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 04:32:18 +0100
commit20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c (patch)
treebbf62cb65ba716e7cefcfc41904bb3460c3ddb58 /src/crypto/cipher/aes128_ctr/CMakeLists.txt
parentde66ca829d22f939900635968d1b3fd7a7d598da (diff)
downloadfastd-20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c.tar
fastd-20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c.zip
Implement the first step towards a more flexible way to support crypto methods
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/crypto/cipher/aes128_ctr/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
new file mode 100644
index 0000000..6237a7c
--- /dev/null
+++ b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(IMPLS "")
+
+if(WITH_CIPHER_AES128_CTR_NACL)
+ list(APPEND IMPLS nacl)
+endif(WITH_CIPHER_AES128_CTR_NACL)
+
+set(IMPL_SOURCES "")
+
+foreach(impl ${IMPLS})
+ add_subdirectory(${impl})
+
+ list(APPEND IMPL_SOURCES $<TARGET_OBJECTS:cipher_aes128_ctr_${impl}>)
+endforeach(impl)
+
+
+set(CIPHER_NAME "aes128-ctr" PARENT_SCOPE)
+set(IMPLS "${IMPLS}" PARENT_SCOPE)
+set(IMPL_SOURCES "${IMPL_SOURCES}" PARENT_SCOPE)