summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-10-18 20:11:30 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-10-18 20:11:30 +0200
commit4b8c4f54bbd70849fc91679bea44b4e1dfb0526d (patch)
treeb23facd97de04a90f99c7ef07af79d3d978a91d5 /src/crypto/cipher/aes128_ctr/CMakeLists.txt
parent878e6e10f3c7ea7a7090a0b2a4289b8d3eef57b9 (diff)
downloadfastd-4b8c4f54bbd70849fc91679bea44b4e1dfb0526d.tar
fastd-4b8c4f54bbd70849fc91679bea44b4e1dfb0526d.zip
cipher: remove aes128-ctr NaCl implementation
New versions of libsodium have dropped support for aes128-ctr. AES support is only available with OpenSSL now.
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/crypto/cipher/aes128_ctr/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
index 0588fed..58e8c6b 100644
--- a/src/crypto/cipher/aes128_ctr/CMakeLists.txt
+++ b/src/crypto/cipher/aes128_ctr/CMakeLists.txt
@@ -1,3 +1,2 @@
fastd_cipher(aes128-ctr aes128_ctr.c)
add_subdirectory(openssl)
-add_subdirectory(nacl)