summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 04:32:18 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 04:32:18 +0100
commit20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c (patch)
treebbf62cb65ba716e7cefcfc41904bb3460c3ddb58 /src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
parentde66ca829d22f939900635968d1b3fd7a7d598da (diff)
downloadfastd-20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c.tar
fastd-20ee3b5a4f110f53a73746e18fc0eb0cbbb7845c.zip
Implement the first step towards a more flexible way to support crypto methods
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
new file mode 100644
index 0000000..50e4b4c
--- /dev/null
+++ b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories(${FASTD_SOURCE_DIR}/src ${FASTD_BINARY_DIR} ${NACL_INCLUDE_DIRS})
+
+add_library(cipher_aes128_ctr_nacl OBJECT
+ cipher_aes128_ctr_nacl.c
+)
+set_property(TARGET method_xsalsa20_poly1305 PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")