summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 18:28:22 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 18:28:22 +0100
commit8764a80ac01c5b37e6657db07bba7323e2a61906 (patch)
tree7f52203bacce47a52e22da909fc4cf07128381ca /src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
parent38b7d50694b4a9929cc0d5bca884a52d5aeaa8a4 (diff)
downloadfastd-8764a80ac01c5b37e6657db07bba7323e2a61906.tar
fastd-8764a80ac01c5b37e6657db07bba7323e2a61906.zip
More CMake cleanup and fixes
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
index 60479ab..ab0d0e8 100644
--- a/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
+++ b/src/crypto/cipher/aes128_ctr/nacl/CMakeLists.txt
@@ -1,6 +1,5 @@
-include_directories(${FASTD_SOURCE_DIR} ${FASTD_BINARY_DIR}/src ${NACL_INCLUDE_DIRS})
-
add_library(cipher_aes128_ctr_nacl OBJECT
cipher_aes128_ctr_nacl.c
)
-set_property(TARGET method_xsalsa20_poly1305 PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")
+set_property(TARGET cipher_aes128_ctr_nacl PROPERTY COMPILE_FLAGS "${FASTD_CFLAGS}")
+target_include_directories(cipher_aes128_ctr_nacl PRIVATE ${NACL_INCLUDE_DIRS})