summaryrefslogtreecommitdiffstats
path: root/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-27 20:28:16 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-27 20:28:16 +0100
commitba5abca808dc85e2de2e11351832329f1566bc7e (patch)
tree6f5d83fa8abccd17b389b38251e835c11fb968f0 /src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
parent2f516f9ceaaf5b964de953aae82498818db9091b (diff)
downloadfastd-ba5abca808dc85e2de2e11351832329f1566bc7e.tar
fastd-ba5abca808dc85e2de2e11351832329f1566bc7e.zip
Add OpenSSL-based aes128-ctr implementation
Diffstat (limited to 'src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt')
-rw-r--r--src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt b/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
new file mode 100644
index 0000000..5454b3f
--- /dev/null
+++ b/src/crypto/cipher/aes128_ctr/openssl/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(USE_OPENSSL)
+ fastd_cipher_impl(aes128-ctr openssl
+ aes128_ctr_openssl.c
+ )
+ fastd_cipher_impl_include_directories(aes128-ctr openssl ${OPENSSL_INCLUDE_DIRS})
+endif(USE_OPENSSL)